ePRINTit - SRFax - Fax Service is down – Incident details
ePRINTit Documentation
Get updates
Email
ePRINTit Documentation
Get updates
Dark mode
All systems operational
SRFax - Fax Service is down
Resolved
Degraded performance
Started 23 days ago
Lasted about 24 hours
Affected
Faxing Services
Degraded performance from 5:41 PM to 5:11 PM
SRFax - Fax Service
Degraded performance from 5:41 PM to 5:11 PM
Updates
Resolved
February 11, 2026 at 5:11 PM
Resolved
February 11, 2026 at 5:11 PM
Faxing Services, SRFax - Fax Service are back up. This incident was automatically resolved by Instatus monitoring.
Monitoring
February 10, 2026 at 5:41 PM
Monitoring
February 10, 2026 at 5:41 PM
SRFax - Fax Service is down at the moment. This incident was automatically created by Instatus monitoring.